Home > C Compiler > C Compiler Cannot Create Executables Arm-linux-gcc

C Compiler Cannot Create Executables Arm-linux-gcc

no configure: error: in `/home/toai/AndroidFFmpeg/FFmpegLibrary/jni/vo-amrwbenc': configure: error: C compiler cannot create executables See `config.log' for more details please help me in this step. What is really curved, spacetime, or simply the coordinate lines? Does sputtering butter mean that water is present? Solutions? his comment is here

checking for correct TEA configuration... Creating a table with FIXED length column widths Storage of a material that passes through non-living matter Newton's second law for individual forces First Skills to Learn for Mountaineering Why had Do students wear muggle clothing while not in classes at Hogwarts (like they do in the films)? Completing the CAPTCHA proves you are a human and gives you temporary access to the web property. imp source

It is pointing to i686-android-linux-gcc whereas the folder only contains a file named i686-linux-android-gcc. Is it possible to bleed brakes without using floor jack? How can I check that the voltage output from this voltage divider is 2.25V? This site is not affiliated with Linus Torvalds or The Open Group in any way.

Do students wear muggle clothing while not in classes at Hogwarts (like they do in the films)? Determine maximum frequency of input signal to make system LTI Is there a name for the (anti- ) pattern of passing parameters that will only be used several levels deep in In the initial setup of configuring , I try Shell$ ./configure --host=ARM configure: WARNING: If you wanted to set the --build type, don't use --host. Depalindromize this string!

yes checking for strchr... configure:2693: checking build system type configure:2707: result: i686-pc-linux-gnu configure:2727: checking host system type configure:2740: result: arm-none-linux-gnueabi configure:2760: checking target system type configure:2773: result: arm-unknown-linux-gnueabi configure:2864: checking for arm-none-linux-gnueabi-gcc configure:2880: found /home/andree/CodeSourcery/Sourcery_G++_Lite/bin/arm-none-linux-gnueabi-gcc I also found that by including 'O3' in CFLAGS it can be solved. http://stackoverflow.com/questions/27139009/configure-error-c-compiler-cannot-create-executables-while-compiling-python-fo i686-pc-linux-gnu checking host system type...

none needed checking how to run the C preprocessor... /home/user1/toolchain/toolchain/arm-none-linux-gnueabi/bin/arm-none-linux-gnueabi-gcc -E checking for a BSD-compatible install... /usr/bin/install -c checking whether make sets $(MAKE)... The cannot create executables message sometimes indicates that the filesystem doesn't support Unix-style permissions (e.g. Join them; it only takes a minute: Sign up Here's how it works: Anybody can ask a question Anybody can answer The best answers are voted up and rise to the How is it packed?

yes checking for /home/user1/toolchain/toolchain/arm-none-linux-gnueabi/bin/arm-none-linux-gnueabi-gcc option to accept ANSI C... my site One more step Please complete the security check to access forum.kodi.tv Why do I have to complete a CAPTCHA? more stack exchange communities company blog Stack Exchange Inbox Reputation and Badges sign up log in tour help Tour Start here for a quick overview of the site Help Center Detailed configure: error: Expect can't be cross compiled linux arm cross-compilation expect share|improve this question edited May 18 '15 at 20:21 Tshepang 17.6k52147232 asked Jan 27 '13 at 17:20 m4n07 131114 add

yes checking for timezone... this content no checking build system type... no checking build system type... ACLOCAL=” AMDEPBACKSLASH=” AMDEP_FALSE=” AMDEP_TRUE=” AMTAR=” AM_BACKSLASH=” AM_DEFAULT_VERBOSITY=” APPLE_FALSE=” APPLE_TRUE=” AR=” AUTOCONF=” AUTOHEADER=” AUTOMAKE=” AWK=” BOOST_PYTHON_LIBS=” BOOST_THREAD_LIB=” CC=’arm-none-linux-gnueabi-gcc’ CCDEPMODE=” CFLAGS=’-I/usr/arm-linux-gnueabi/include/gtk-2.0 -I/usr/arm-linux-gnueabi/include/glib-2.0′ CPP=” CPPFLAGS=” CXX=” CXXCPP=” CXXDEPMODE=” CXXFLAGS=’-I/usr/arm-linux-gnueabi/include/gtk-2.0 -I/usr/arm-linux-gnueabi/include/glib-2.0/ -I/usr/arm-linux-gnueabi/lib/glib-2.0/include/ -I/usr/arm-linux-gnueabi/include/pango-1.0 -I/usr/arm-linux-gnueabi/include/cairo/ -I/usr/arm-linux-gnueabi/include/librsvg-2′

any idea? yes checking for suffix of executables... member jacek-marchwicki commented Apr 16, 2013 You probably need to fix android_build.sh. weblink Reload to refresh your session.

Then look above the error for a command line like gcc -D_ISOC99_SOURCE -std=c99 -E -o /tmp/ffconf.blSwtBlI.o /tmp/ffconf.b17GLMRQ.c You can also look toward the end of config.log, seeing if you can spot The only thing I did different was it seems the environment path for NDK had to be set directly to the compiler. This is free software: you are free to change and redistribute it.

Already have an account?

Invocation command line was $ ./configure –target=arm-linux-gnueabi –host=arm-none-linux-gnueabi –with-sdl-prefix=/usr/arm-linux-gnueabi –prefix=/home/andree/CodeSourcery/Sourcery_G++_Lite/lib Platform. yangbo001 commented Dec 19, 2014 the ndk version is wrong,you can open the build_android.sh file to change PREBUILT=$NDK/toolchains/arm-linux-androideabi-4.6/prebuilt/$OS-x86_64 ......and so on ,to match your ndk version. My manager said I spend too much time on Stack Exchange. Target: arm-none-linux-gnueabi Configured with: /scratch/mitchell/builds/4.3-arm-none-linux-gnueabi-respin/src/gcc-4.3/configure –build=i686-pc-linux-gnu –host=i686-pc-linux-gnu –target=arm-none-linux-gnueabi –enable-threads –disable-libmudflap –disable-libssp –disable-libstdcxx-pch –with-gnu-as –with-gnu-ld –with-specs=’%{funwind-tables|fno-unwind-tables|mabi=*|ffreestanding|nostdlib:;:-funwind-tables}’ –enable-languages=c,c++ –enable-shared –enable-symvers=gnu –enable-__cxa_atexit –with-pkgversion=’Sourcery G++ Lite 2009q1-203′ –with-bugurl=https://support.codesourcery.com/GNUToolchain/ –disable-nls –prefix=/opt/codesourcery –with-sysroot=/opt/codesourcery/arm-none-linux-gnueabi/libc –with-build-sysroot=/scratch/mitchell/builds/4.3-arm-none-linux-gnueabi-respin/lite/install/arm-none-linux-gnueabi/libc –with-gmp=/scratch/mitchell/builds/4.3-arm-none-linux-gnueabi-respin/lite/obj/host-libs-2009q1-203-arm-none-linux-gnueabi-i686-pc-linux-gnu/usr –with-mpfr=/scratch/mitchell/builds/4.3-arm-none-linux-gnueabi-respin/lite/obj/host-libs-2009q1-203-arm-none-linux-gnueabi-i686-pc-linux-gnu/usr –disable-libgomp

You can fix the problem by making symlinks in the android-ndk-{version}/toolchains/x86-4.4.3/prebuilt/linux-x86/bin folder with the 'correct' names. Why does Friedberg say that the role of the determinant is less central than in former times? Please try to give the least useful info for the problem. –mtk Mar 15 '13 at 9:55 i get this errors and i see the synaptic Package Manager i check over here Do students wear muggle clothing while not in classes at Hogwarts (like they do in the films)?

Join them; it only takes a minute: Sign up Here's how it works: Anybody can ask a question Anybody can answer The best answers are voted up and rise to the Thanks again for the great work. configure: error: C compiler cannot create executables0configure: error: C compiler cannot create executables: wxPython 3.0.2.01how to configure: error: C compiler cannot create executables0Issue compiling OpenMPI with ifort0arm-none-eabi returns error when compiling0Configure